[thelist] [mod_perl/Apache::DBI] undefined symbol: PL_dowarn

Anthony Baratta Anthony at Baratta.com
Tue Mar 20 13:33:25 CST 2001

At 10:52 AM 3/20/2001, you wrote:
>Hi Anthony,
>I took the liberty of asking my boyfriend to have a look at this (he's
>much better @ things like this than me.....mind you he's been doing it
>for years!) and I've enclosed his response.

I knew that I should have compiled mod_perl when I installed SSL support. 
sigh. The biggest challenge for me is that I've already installed mod_ssl 
and its working great. I have a client depending on that and I don't want 
to break it by  recompiling Apache to support mod_perl statically. I'm just 
afraid of screwing it up. sigh.

I really appreciate the information. I'm not the expert, but his solution 
is very lucid and most probably the correct thing to do - including moving 
to Perl 5.6.

It's just the recompile of practically everything I've got setup, and then 
the reinstall of all the specialty perl modules that I already have 
installed. (They are not carried over during an upgrade like this, AFAIK.)

I see a weekend job brewing here.

Anthony Baratta
Keyboard Jockeys

More information about the thelist mailing list