[thelist] Is there a cookie problem with IE 5?

Jill Shaw jillshaw at email.com
Fri Aug 24 10:53:29 CDT 2001

Hi folks
I've discovered a weird thing happening with IE 5 and cookies. I'm using ASP to set 2 cookies when a user logs in. Once inside the site some pages are 'personal' and therefore reference the cookies. This was working fine until a few days ago (and still works in Netscape 4.7) - but now the login page seems to kill the cookie as it moves to a new page. 

I have an 'expires' instruction doing something like
Response.Cookies("COOKIENAME_cookie").Expires = Date + 1

and have found that changing it to  + 100 makes the whole thing work. (Why?)
I have checked around on the web and saw someone mention that this line should come before any cookies are set - tried that and it doesn't help. Have also tried the cookie with all lowercase letters - still no go.

Has anyone else had this problem? Does anyone know how to fix it?
Thanks in advance,

<tip type="radio button validation" author="Jill Shaw">
Radio button validation can be achieved quite easily with the following procedure...

1. in the button tag add onCLick="varname='true'" to each radio button in the group
2. in the script tag declare your global variable and set it to false - ie var varname="false"
3. in the function called from the form submission, add Javascript with appropriate variable name - ie 
if (varname=="false"){
	alert("Please select a radio button"); 
        return false;

This took me an age to work out - hope this tip saves somebody some time!

Talk More, Pay Less with Net2Phone Direct(R), up to 1500 minutes free! 

More information about the thelist mailing list