[thelist] Apache 2.0.18 + PHP 4.06

Andrew Forsberg andrew at thepander.co.nz
Fri Sep 28 22:51:43 CDT 2001


I was wondering if any one on the list had successfully compiled PHP 
4.0.6 to work with Apache 2.0.18. The


option just isn't doing it for me.  The problem may be platform 
dependent (Solarix 8 x86, 7/01, gcc 2.95.3 + gmake 3.78.1), but I'd 
be surprised.

Anyone have any suggestions?


<tip type="configuring php 4.0.6 for apache 1.3.20">
If you get errors when starting apache 1.3.20 after successfully 
compiling php 4.0.6, try using the --with-zlib configure option. it's 
probably a good idea to 'make distclean' before running ./configure a 
second (or fortieth) time, too. It seems that at least some platforms 
(from personal experience: MacOS X, and Solaris 8 x86) seem to need 
--with-zlib explicitly stated in the configure options. I don't 
remember having to do this with previous versions.

Also, it appears that pear won't install from php 4.0.6 sources, so 
don't bother banging your head on that one.

Andrew Forsberg
the pander - http://thepander.co.nz/
uberNET - http://uber.net.nz/

More information about the thelist mailing list