[thelist] AutoCompletion with Ajax and z-index Problems

Stefan Schwarzer st.schwarzer at geois.de
Wed Oct 11 01:27:40 CDT 2006

Ok, I found the problem. The z-index was specified in the javascript  
file. I had to change it there.

Thanks for you help.


> Hello,
> I'm a little late to this party, and it's quite possible that you've
> been tinkering on the posted URL's code since you posted this, but ...
> On 10/2/06, Stefan Schwarzer <st.schwarzer at geois.de> wrote:
>> Actually, unfortunately it's not the MSIE problem. It concerns all
>> browsers...
> 1) Strangely, IE7RC1 does not exhibit this problem (the autocomplate
> list getting under the map image). But Firefox does. Just for data
> points.
> 2) Like I said, it's possible that the code that's there now isn't
> what you referred to in the original post, but it would seem that the
> for those two relevant elements, you have inline CSS defining their
> z-indexes. However, the z-index for the map is 6, while the z-index
> for the autocomplete section is 1. That means the map *should* be on
> top, at least according to the inline CSS.
> It's complex enough that I might have overlooked something in the few
> minutes I gave it, but that's what I saw.
> -- 
> Todd Stadler, tstadler at gmail.com
> "You try to warn them that the world's gone mad, but they won't listen
> to you" -Snoopy
> -- 
> * * Please support the community that supports you.  * *
> http://evolt.org/help_support_evolt/
> For unsubscribe and other options, including the Tip Harvester
> and archives of thelist go to: http://lists.evolt.org
> Workers of the Web, evolt !

More information about the thelist mailing list