[thelist] module install failure - Joomla

Bob Meetin bobm at dottedi.biz
Wed Dec 17 11:45:32 CST 2008

I am testing a Joomla component which I cannot get to install and unfortunately cannot name it here.  In Joomla 1.5+ you install components, modules etc through 
the admintool, very straight-forward

1) from the Joomla administration panel I select Extensions --> Install/Uninstall

2) I used all the installation options:
    Upload Package File
    Install from Directory
    Install from URL

*) I cannot get it to successfully install so  did the common install procedures in option 2 above on 2 different operating systems and several browsers:

Ubuntu Linux & Firefox
Ubuntu Linus & Konqueror
Ubuntu Linux & Epiphany
WinXP & Firefox
WinXP & IE

Full Error Message:
* Error! Could not find an XML setup file in the package.

Warning: zip_read() expects parameter 1 to be resource, integer given in /home/dhoward/public_html/j/libraries/joomla/filesystem/archive/zip.php on line 234

Warning: zip_close() expects parameter 1 to be resource, integer given in /home/dhoward/public_html/j/libraries/joomla/filesystem/archive/zip.php on line 250
Unable to find install package

I gave the developer admin access to try himself and for him it works flawlessly, cannot reproduce the error. The only differences are that he uses a Mac and it 
takes him 10 vs 20 seconds for the upload/install to process.  If I google the error it seems to talk to a problem with zip_open or zip_read (Joomla) but if 
this were so, then why would anything work for me and why does it work for him?

Idaas? Bob

More information about the thelist mailing list