[Javascript] Retaining values

J. Lester Novros II lester at denhaag.org
Sat Apr 16 08:37:17 CDT 2011


Tedd,

Hmm... Strange. I sent this out yesterday and never saw it turn up on the list 
so I'll send it again. I apologize beforehand for any duplication.

On 04/15/2011 06:26 AM, tedd wrote:
> I would like your review, if you would be so kind.

Nothing much to add except that I would append the new tr to the 'place' table 
rather than generate a new table, and add a classname to the new td like so:

     td.className = 'newTDclassName';

which would obviate the need for the 'style' property.

If you do the same for the input elements you'll have complete separation of 
style and script.

Also, to avoid code duplication, you could have a function to generate a table 
cell with an input in it, using 'name' and 'size' as function arguments and 
feed its output to the tr 'appendChild' method.

l8R lES
-- 
The key used for communication between the operators and the SIM card is very
well protected, because it protects their monetary interest. The other key is
less well protected, because it only protects your private data.
                                       SRLabs' Karsten Nohl on the SIMcard hack
http://lester.demon.nl/superm                    http://lester.demon.nl/tonka


More information about the Javascript mailing list