[thelist] Awstats cronjob problem

CDitty mail at redhotsweeps.com
Wed Jan 2 19:30:22 CST 2002

Good idea.  Just tried it.  Didn't work.  Same error.  Tried changing the 
config name and same error.  I must be missing something.


At 06:44 PM 1/2/2002, you wrote:
>At 04:23 PM 1/2/2002, CDitty wrote:
>>Now to the problem......
>>I have installed and configured awstats for my server. Everything is 
>>running fine with the exception that I cannot get awstats to update via 
>>cron.  This is what I have in my crontab - /home/httpd/cgi-bin/awstats.pl 
>>-config=myconfig -update
>>This is the error that I get - Error: Couldn't open config file 
>>"awstats." nor "awstats.conf" : No such file or directory
>>Awstats will update if I run the update command from the cgi-bin 
>>directory via telnet.
>Maybe you should setup a shell program that changes to the proper 
>directory then executes the target program for you.
>e.g. in cron
>then in awstats_update
>cd /home/httpd/cgi-bin/
>./awstats.pl <blah blah blah>
>Anthony Baratta
>Keyboard Jockeys
>"Conformity is the refuge of the unimaginative."
>For unsubscribe and other options, including
>the Tip Harvester and archive of TheList go to:
>http://lists.evolt.org Workers of the Web, evolt !

More information about the thelist mailing list