[thelist] PAGE OPTIMIZATION: source readability v. download w eight

Tom Dell'Aringa pixelmech at yahoo.com
Wed Jun 12 15:24:01 CDT 2002


--- Jonathan_A_McPherson at rl.gov wrote:
>
> > I would do . . .
> >
> > if (this == this) {
> >     do me;
> > } else {
> >     do me;
> > }
> >
> > it's cleaner
>

This particular discussion is interesting.

Define "cleaner"...to me "cleaner" is a subjective term. Whats clean to one, isn't to another. For
ages I preferred the above method...but...then I saw people using the other way

blah()
{
 more blah
}

And when my code starting getting longer I realized that *for me* it was much easier to read. So
I've started doing all my JS like this and really liking how it helps me find functions faster and
allows me to read it easier. I don't say this is the right or wrong way, just the way I prefer. To
*me* its "cleaner."

> Not only is it cleaner, it's also the style used by K&R, the authors of C
> (which has since been used as a basis for C++, Java(Script), C#, etc). It's
> considered standard. I prefer it, too

Who cares? Anyone on this list is just as valid a JS user as they.

> And so does Linus Torvalds!

Ditto for you Linus - who cares. Celebrity hardly makes one opinion more valid than another's.

> http://adamspiers.org/computing/Linus-Kernel-CodingStyle
>
> --
> Jonathan McPherson, LMIT/SD&I
> Software Engineer & Web Systems Analyst
> email / jonathan_a_mcpherson at rl dot gov
> phone / 509.373.0150
> --
> For unsubscribe and other options, including
> the Tip Harvester and archive of thelist go to:
> http://lists.evolt.org Workers of the Web, evolt !


__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com



More information about the thelist mailing list