[thelist] ASP: More Selective Select

Koutoulas, Pete PKOUTOUL at Fayette.k12.ky.us
Thu Jul 3 08:38:46 CDT 2003

On Thursday, July 03, 2003 12:31 AM, rudy wrote:

> casey, a more important rule than using plural names for tables is
> NOT to embed the "type of the thing" into the name of the thing
> for example, do not say  tblEmployees  or  colFirstname

Rudy, you're the db guru, but you just blew away 10 years of best practice
for me! I have proudly used naming conventions that prepend the object type
("tblEmployees", "qryEmployees", etc.). It's used in almost all the books I
have read, especially those covering Access/VB and I have continued to use
it as I moved on to SQL Server. I find it helpful to know the object type
when looking at the code, sort of like when you prepend the data type to a
variable, as in "intYears" or "strSQL" or "rstMyRecordset." This kind of
thinking is so ingrained in my head I could never get rid of it. Why do you
say not to do that? (I assume you are only talking about database objects
and not variable names?)

Pete Koutoulas, Website Manager
Fayette County Public Schools
701 E. Main Street
Lexington, KY 40502
Voice (859) 381-4138
Fax (859) 381-4763
webmaster at fcps.net

This student or staff email originated from Fayette County Public Schools in
Lexington, KY. 
Please report instances of abuse or inappropriate content to
postmaster at fayette.k12.ky.us 

More information about the thelist mailing list