[thelist] Setting permissions so localhost can be used by Firefox

Ken Schaefer Ken at adOpenStatic.com
Fri Jul 22 19:08:18 CDT 2005

That looks fine.

You have anonymous access enabled, and IIS is controlling the password for
that account.

However the next problem could be that the configured anonymous account
(IUSR_<machinename>) doesn't actually have NTFS permissions to read the file
off the hard disk.

If you locate the file on your hard disk (typically somewhere under
c:\inetpub\wwwroot\), right-click and choose "security", what are the
effective permissions to that file for the IUSR_<machinename> account?

Additionally, do you have a global.asa file? If so, the IUSR account needs
permissions to that as well, since that gets processed when the application
starts, or a new user connects to the machine.

If you want an idea of how these requests get processed, check out my FAQ:


: -----Original Message-----
: From: thelist-bounces at lists.evolt.org [mailto:thelist-
: bounces at lists.evolt.org] On Behalf Of Michele Foster
: Sent: Saturday, 23 July 2005 6:14 AM
: To: todd at promisingsites.com
: Cc: thelist at lists.evolt.org
: Subject: Re: [thelist] Setting permissions so localhost can be used by
: Firefox
: On 22/07/05, Todd Richards <todd at promisingsites.com> wrote:
: >
: > Michele -
: >
: > I apologize, as I'm a little confused on what is going on here. However,
: > have you checked the security settings in IIS to make sure that
: anonymous
: > access is allowed?
: >
: > Todd
: I'm not 100% sure where to check this .. as I've compared my settings on
: Win2K and my WinXp machine and the settings appear to me to be the same.
: It's the new WinXP Pro machine that is not working.
: I go to IIS, displayed is one entry my Computer's name (local computer)
: Then I go to Web Sites or Default Web Site (I've tried both)
: Right click, Properties
: Directory Security
: Anonymous access and authentical control, Choose Edit
: on that screen "Authentication Methods"
: Selected is Anonymous access (at the very top) and the last option
: Integrated Windows Authentication
: Under Anonymous access it says, Account used for anonymous access: and the
: values are IUSR_MyComputerName with a Password that I have no idea what it
: is, and the check box "Allow IIS to control password" selected.
: I tried to delete this user name, but it won't let me (gives me an error
: and
: says enter at least one character)
: I don't know if I'm close or not .. this is rather frustrating.
: Yes, I have googled, but I no longer have any clue what I'm even looking
: for.
: Thanks everyone for your help
: Mich

More information about the thelist mailing list