[thelist] md5 hashed password problem

Bob Meetin - 303-926-0167 - www.dottedi.biz bobm at dottedi.biz
Wed Aug 15 08:28:11 CDT 2007


In moving a registration system from a shared hosting provider to 
another I ran into a problem with the passwords not authenticating.  I 
have gone to the old site and manually copied the encrypted password 
into the password field, very careful, no extra spaces.  Visually they 
look identical.

*3BDC3D5E6C0386BD93B2C9F79C9B0D92D05714TT  ==> the encrypted password in 
the mysql database appears identical on both sites/providers

select * from members where login='some_member' AND 
select * from members where login='some_member' -->> this returns a record

If I run the select statement (above) on the login field only it returns 
a record, meaning that it is connecting to the database and seeing the 
table correctly.  I set up an echo which echoes back what the user types 
in, the entered password, and that seems to be fine.


"This is because each server has an md5 function that deciphers hashed passwords such as this. If you moved the scripts location on your server it would work, but not if you move this to another server. You will need to find some way to reset this file in the database system."

OK - this seems reasonable as an explanation, but still I'm rather at a loss.  Can anyone recommend a worksround, a way to convert, decrypt, whatever, so that I can transfer about 20 accounts to the new provider without having to go through hoops with the members/shareholders?


More information about the thelist mailing list