[thelist] HV menu "phantom line" problem

Duncan Hill dunkaz at gmail.com
Tue Mar 11 19:06:56 CDT 2008

On Tue, 11 Mar 2008 21:28:14 -0000, Gersten, John <JGERSTEN at lchb.com>  

> I recently added a horizontal "HV" menu from Dynamic Drive to one of our  
> sites so as to provide multi-level menu functions that could (at least  
> sometimes) be properly read/rendered by IE6. (I really wanted to go the  
> CSS route, but could not find a CSS-driven menu that would work to  
> properly show menu sub-levels in IE6).
> Soon after posting the pages with the HV menu, I realized that something  
> in the script was throwing a one-pixel red line underneath the menu  
> itself. This line appears to be #800001 in color (a color that was  
> originally utilized in the menu script for a hover background, but has  
> been replaced with pink in this example). I cannot figure out what is  
> causing the "#800001" one-pixel line to appear.
> If you look at this page,  
> http://www.lieffcabrasersecurities.com/working.htm, you should be able  
> to see the "phantom" red line. The extra line runs the full width of the  
> table containing the menu, even though the menu only appears in the 500  
> rightmost pixels of the table.
> If anyone could explain where this extra line is coming from (not to  
> mention how to remove it) I'd be extremely grateful.
> Thanks in advance.
> John

Hi John,

You've fixed your problem now but on the menu subject did you look at Son  
of Suckerfish, it only takes a very small piece of javascript to give IE6  
full functionality, everything else handles the menu with just CSS.
I think it is on http://www.htmldog.com/articles/

Best wishes


More information about the thelist mailing list