[thelist] iframe ignoring base target

Joel Canfield joel at bizba6.com
Mon Jan 18 13:45:14 CST 2010

On Mon, Jan 18, 2010 at 11:31 AM, John List <johnlist at gulfbridge.net> wrote:

> On 01/18/2010 02:07 PM, Joel Canfield wrote:
>> Any insights into why the iframe on this page (and others) ignores the
>> base
>> target set in the head of the document?
>> http://www.goldenstateoutdoorsman.com/forum.php
>> I'm thinking it's because the <base> tag only applies to the current
> document.

that would be an answer, if it's correct. you don't sound sure . . .

> But what is it you are trying to accomplish?

when someone clicks a link within the iframe, it loads the content into the
iframe as expected. if they've scrolled waaaaaay down the page to follow
said link, the new frame content is loaded with focus waaaaaay down *that*
page, forcing the user to scroll up to see the top of the forum topic

> Are you trying to retain the parent "frameset" when the user opens a link
> in a new window?

nope; in this case, since there doesn't seem to be a way to get target
documents to load with focus on the *top* of the document, I'm trying to get
them to open in the full window, sans parent frame. at least then the links
will all behave as the users of this forum expect.

> All of which begs the question: why are you using frames? :)

because I don't know another way to have the header, navigation, and other
content combined with the forum software, which doesn't include those

I'm open to other ideas, though.


More information about the thelist mailing list