[thelist] Old Firefox versions won't display page

Lee Kowalkowski lee.kowalkowski at googlemail.com
Thu Apr 19 04:00:51 CDT 2012

On 18 April 2012 23:14, Garth Hagerman <hagerman at mcn.org> wrote:
> Hello-
> I've got an odd problem with one of my clients' sites. The homepage of Bored Feet Press:
> <http://boredfeet.com/index.html>
> Does not display on certain old versions of Firefox. The only one I've been able to confirm the problem on is v 3.5.6 on Windows XP; the client and one of his friends have problems with that page on their FF/Mac combos, but I'm not sure exactly which FF version(s) they're using.
> It produces the following error:  "Not Acceptable/ An appropriate representation of the requested resource / could not be found on this server."
> The page displays OK in every other browser/operating system combo under the Sun (well, every one I've tried).
> The HTML and the CSS validate.

It's not a bug in Firefox (your server is choosing to respond with a
406).  I can reproduce it using http://web-sniffer.net/ and selecting
Firefox 3 as the user agent string.

The only difference between success (200) and Not Acceptable (406)
from web-sniffer is the User Agent String:

406: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9)
Gecko/2008052906 Firefox/3.0
200: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

There must be something in your Apache or somewhere, many Google
results suggest it's mod_security.


More information about the thelist mailing list