[thelist] Weird IIS Error

David.Cantrell at Gunter.AF.mil David.Cantrell at Gunter.AF.mil
Tue Oct 22 09:27:01 CDT 2002

I sent a question yesterday regarding inability to use an XML Schema. I've
narrowed the problem down.

Whenever I have a schema file in the same folder with the XML file I want to
load and transform, the validation logic runs properly. It doesn't validate,
but that's a different question I'm struggling with.

The big issue I have is this: I want to keep all of my XML schema in a
single folder obviously, but once I move the schema out of the same folder
as the XML file I run into this very strange error:

	Error Code: -2146697204
	Reason: The server did not understand the request, or the request
was invalid.
	Source: Line 2, Character 80


I've checked MS KB, Google and Google Groups, and I can't seem to find
anything regarding WHY this error is occuring. Like I said, it only occurs
when I have the file in a separate directory. I've tried relative pathnames
(../shared/schema/leftnav.xsd), absolute pathnames
(/ilspo/shared/schema/leftnav.xsd), fully-qualified names
(http://localhost/ilspo/shared/schema/leftnav.xsd) and even put the schema
on another server. Doesn't matter. As long as the schema is NOT in the same
directory it gives the above error.

If it is in the same directory, it tells me I'm using an undeclared root
element, so at least it's reading the schema. I think anyway, though it
tells me I have an invalid root element according to the schema, but the
schema DOES have the root element specified.

ANYWAY, I'm pretty frustrated by this problem. If anyone can help me out,
I'd really appreciate it.

Many thanks in advance! :)

PS I'm using XP Pro, IIS 5.1 and MSXML 4.

More information about the thelist mailing list