[thelist] sendmail 8.12.5-7 problem

Carl J Meyer cjmeyer at npcc.net
Tue Dec 10 17:50:01 CST 2002


I'm not sure what's causing your problem, but here's what I do know:

The Redhat firewall config tool modifies your iptables setup in
/etc/sysconfig/iptables.  That's all it does, AFAIK.  Also, the
interface is poor in that when you open up the tool it does not display
your current settings, it always starts out showing "HIGH" no matter
what you set it to last time you ran it.  But your changes do take
effect, and you can verify your current firewall settings by looking at
/etc/sysconfig/iptables (or using iptables --list).  If the iptables
file doesn't exist, or --list shows all empty chains, then you have no
firewall configured.

If you've set it to "No firewall" and tried, then it doesn't sound like
iptables is the problem - which surprises me, because I'm not sure what
else would do what you're describing.

xinetd is not the problem - I've never seen sendmail run under xinetd,
RedHat doesn't do it by default, and I would never set it up that way.
So unless you specifically set up sendmail to run via xinetd, there's no

It's been a while since I've worked with sendmail configs, but I'm
pretty sure the Cw setting is also not the issue here (you do want to
set Cw to your domain, though).  Cw being wrong won't cause sendmail to
refuse connections (at least I've never seen it do that), it just causes
it to try to relay mail (or bounce it with an "I refuse to relay")
because it doesn't realize that it's supposed to be the final
destination for that message.

So I can tell you many things that are not the issue, but that doesn't
necessarily help much, does it?  :-)

Do you have any other services running on this machine which are
accessible via TCP/IP from external hosts?  Is sendmail the only one not
accepting connections properly?


On Tue, 2002-12-10 at 15:20, Chris W. Parker wrote:
> > -----Original Message-----
> > From: Anthony Baratta [mailto:Anthony at Baratta.com]
> > Sent: Tuesday, December 10, 2002 2:18 PM
> > To: thelist at lists.evolt.org
> > Subject: RE: [thelist] sendmail 8.12.5-7 problem
> > John is also correct about the fire wall manager. If you
> > installed the fire
> > wall manager during installation you should make sure that
> > port 25 (and
> > port 110 for POP) are open for external use.
> (again i'm going from memory here.)
> i do remember seeing a Security Config/Setup utility that was a basic
> firewall configurator. it seems that i was unable to make any changes to
> the settings. for example, the util would open with the current settings
> (i assume. and where it gets these settings i don't know, as john
> mentioned xinetd.conf?), i chose "none" (or something to that affect)
> and clicked 'ok'.
> i then tried to telnet in, nothing happened.
> so i decided i'd reopen the firewall util and see what it said, to my
> dismay, the firewall was back to "high" security and not "none" like i'd
> expected.
> now to my question... is this util related at all to iptables/ipchains
> or is it a separate file/function of the os. i know john mentioned
> xinetd.conf (which i haven't been able to take a look at yet) but i just
> wanted to try and get this cleared up.
> thanks,
> chris.
> p.s. in your opinion would it be a good idea to buy a redhat 8 book? any
> suggestions?
> --
> * * Please support the community that supports you.  * *
> http://evolt.org/help_support_evolt/
> For unsubscribe and other options, including the Tip Harvester
> and archives of thelist go to: http://lists.evolt.org
> Workers of the Web, evolt !

More information about the thelist mailing list