[thelist] Security... Please Make It Easier For Us Non-Tech Types!

Tom Dell'Aringa pixelmech at yahoo.com
Wed Aug 13 12:54:08 CDT 2003


--- Jorah Lavin <madstone at madstone.net> wrote:
> The thing is... unless this is your job, how many people have the
> time? [massive snip]

+1 - I could not agree more! I don't consider myself a non-tech type
either - but I am not a network admin on the other side of the coin
as well. I could certainly understand the concepts that are presented
if they were presented in a way that is digestable.

But who has time to monitor 3 extra lists, bone up on security (while
trying to decide who is tooting their own horn and who is really
telling you what you need) and so on. 

I can keep my patches up to date, I can run ZoneAlarm, but beyond
that...

What would be great is some kind of list or something..who knows.
Anyway..just thought I'd chime in.

Tom

<tip type="javascript" author="pixelmech">

Use the ternary control structure to save space in your code. It's
nice and compact and for an intermediate+ scripter, very nice to use.
Slightly less readable, so be aware of that. 

The format is: 
varResult = (condition) ? result if true : result if false;

So you could change the following IF..ELSE control:

if(virusWorms == "suck")
{
   display = "beat the author senseless";
}
else
{
   display = "hug the author lovingly";
}

to:

display = (virusWorms == "suck") ? "beat the author senseless" : "hug
the author lovingly" ;

A somewhat flippant example, so here is a better one - dynamically
coloring rows:

modRemainder = i % 2;
newClass = (modRemainder == 0) ? "rowColor1" : "rowColor2";
oRows[i].className = newClass;

The middle ternary control there says you a nice block of code. Since
you only want to return a simple class name, it's perfect for this
case.
</tip>

=====
http://www.pixelmech.com/ :: Web Development Services
http://www.DMXzone.com/ :: Premium Content Author / JavaScript / Every Friday!
http://www.maccaws.com/ :: Group Leader
[Making A Commercial Case for Adopting Web Standards]

"That's not art, that's just annoying." -- Squidward


More information about the thelist mailing list