[thelist] CVS Desperation

Burhan Khalid thelist at meidomus.com
Sun Oct 12 16:14:01 CDT 2003

Greetings everyone :

   I am having a real headache trying to setup CVS for remote logins on 
a linux system.  CVS works fine localy, I can checkout and commit 
changes, but whenever I try to login remotely, the server responds with 
"directory not found" or "client closed connection".  I can checkout 
files fine with cvs (from a SSH), but when I try to logon to the server 
itself (from the same machine, using the IP), it doesn't work.

   Here is what I've tried :

   Checked permissions (cvs user, cvs group)
   Edited the passwd file under CVSROOT
   Created a separate cvs-only user and added that to passwd file
   Read the manual at cvshome.org and the "The CVS Handbook"
   Tried logging in as my normal user (member of cvs group), cvs-only 
user, even root.

  Nothing seems to be working. Can anyone point me to any resources or 
offer any clues? Thanks so much.  Things I haven't tried yet are logging 
in via SSH, because I'm trying to figure out if the problem is with 
authentication, or the actual server setup.

I owe a tip.

Eagerly awaiting some advice,
Burhan Khalid

More information about the thelist mailing list