[thelist] MySQL, corrupt tables refuse to fix

Kasimir K evolt at kasimir-k.fi
Fri Jul 29 08:15:25 CDT 2005


on a site I use two databases, both on the same MySQL server, one for 
the content and the other (called 'catalog') for a shopping system.

I started getting symptoms of corrupt tables on both databases, so I 
telnet to server and do:
mysqlcheck --user=[username] --password=[pwd] --repair -A

This fixed the content database, but not 'catalog'. I tried the same 
again, but this time it hanged MySQL and I had to give it a ctrl-c, 
which made MySQL respond again.

Then I tried:
mysqlcheck --user=[username] --password=[pwd] --repair -v catalog
but the only verbose output was:
# Connecting to localhost...
# Disconnecting from localhost...

And I still get errors like:
1017 - Can't find file: './catalog/manufacturers.frm' (errno: 9)
1017 - Can't find file: './catalog/products_attributes.frm' (errno: 9)

Then I:
mysqladmin --user=[username] --password=[pwd] flush-tables

and I start getting messages like:
File './[content DB name]/[table name].MYD' not found (Errcode: 9)

I do mysqlcheck --repair -A again, and other tables go missing.

And so on and on... but never I get both DBs' all tables working ok at 
the same time.

The hosting company has not given any really helpful advice :-( They 
told me "...mysql was upgraded to version 4.x. ... If you want there is 
a process to downgrade back to mysql verion 3.x..." I told them that I 
don't want a downgrade thank you.

Am I doing something stupid or has MySQL server come to its end? Would a 
disk failure look like this? Any other advise?


More information about the thelist mailing list