[thelist] ColdFusion Query of Queries Syntax Error

Chris Hayes chris at lwcdial.net
Wed Jul 19 12:22:28 CDT 2006

I remember some noise about about MX using typed data fields when CF5 was 
typeless but I wasn't paying much attention at the time. I don't know the 
issues or what was fixed and when.

Best advice is to apply all hotfixes and see if that does it.  If you can 
upgrade to 7 then do.

If it is a type issue, there are no more hotfixes, you can't upgrade CF AND 
you really need to do this than you could try changing you initial query to 
break down the date into three fields:

     year, month and day

and changing your QoQ to

year < #year(now())#  or (
        year = #year(now())# and (
            month < #month(now())# or (
                month = #month(now())# and day < #day(now())#

!!! I just made that up,  no idea if it's right.

----- Original Message ----- 
From: "Minh Lee Goon" <evolt at goonies.info>
To: <thelist at lists.evolt.org>
Sent: Wednesday, July 19, 2006 5:45 PM
Subject: Re: [thelist] ColdFusion Query of Queries Syntax Error

> When I query the database directly with the same SQL statement, it works
> fine. Is there a QoQ bug? The database is MS Access, but I had the same
> problem with MySQL.
> Minh Lee Goon wrote:
>> When I use a QoQ, I keep getting a syntax error when I know it has
>> worked in another version before. I'm on 6,1,0,63958 now, and it has
>> worked with 7,0,1,116466. Is there a hot fix for this? Or a feature that
>> needs to be turned on?
> -- 
> * * Please support the community that supports you.  * *
> http://evolt.org/help_support_evolt/
> For unsubscribe and other options, including the Tip Harvester
> and archives of thelist go to: http://lists.evolt.org
> Workers of the Web, evolt !

More information about the thelist mailing list