[Theforum] Re: Zope and NN

Garrett Coakley garrett at polytechnic.co.uk
Thu May 9 04:20:52 CDT 2002

On Wed, May 08, 2002 at 07:00:26PM -0600, Dean Mah wrote:

> Unfortunately, I've been told that Zope requires Python 2.1 to work.
> We are using Python 2.2 and I don't think it would be wise to
> downgrade since MG uses Python on that box currently.

You know you can have different versions of python running on the same
machine[1]. I hit the same problem when I wanted to run Zope on my
powerbook (running mandrake 8.2). It had Python 2.2 (well, still has), and
it now has 2.1 installed next to it.

Even this box that I'm on now (which hosts spiked.co.uk) has multiple

[garrett at spiked garrett]$ ls -1 /usr/bin/python*


[1] Of course this is apart from the question *should* we install another
version of python and risk breaking MG. Everything worked fine here, but
I'd suggest we do some testing first. Is teo a seperate box?

More information about the theforum mailing list