This sounds like something that the Composite design pattern should be able to handle. This simplifies designs and allows for easy extensibility. Check out: http://www.hillside.net/patterns/DPBook/DPBook.html Dean Joshua OIson writes: > The other reason I suggest not using the application scope is also > extensibility. What if you want to change the information to > "last-5-per-forum-or-per-article-category" In a DB you could just > add an category_id field and change the triggers/SQL accordingly, > whereas in application variables you'd have to rework the entire > naming convention and do a whole lot of "evaluates" or some other > kludgy method to insert and extract the information. At some point > it becomes not worth it.