[thelist] SSI Help

sarah disaster7 at yahoo.com
Wed Feb 14 15:56:03 CST 2001

What you said is exactly what I'm doing and it doesn't
work in the subdirectories. I can't show you the URL
because its internal but I can try my best to
illustrate what I'm doing:

The file I want to include is /inc/footer.ssi

The files in the root (the only file is /index.html)
work fine with:
<!--#include file="inc/footer.ssi" -->

The files in sub directories (/dir/index.html) do not
work with anything I've tried. I know you can't use
../ and absolute paths. I've tried both of these and
neither of them work.
<!--#include file="/inc/footer.ssi" -->
<!--#include virtual="/inc/footer.ssi" -->

Again its Netscape Enterprise Server4 SP 2 on Solaris.
I get [an error occurred while processing this
directive] where the footer should be. 

Anyone have an idea what the issue is? 

--- "A. Erickson" <amanda at gawow.com> wrote:
> You can use any kind of path you want with SSI.
> However, a relative from
> root path usually works best as it can then insert
> itself into any file on
> that URL and work just fine.
> relative from root paths looks like this:
> "/path/foo.html" as you have
> below.
> If you're having trouble getting your ssi to work
> then maybe it is the way
> you are calling the ssi?
> Make sure that the document which references the
> include has that reference
> written properly like this, with no space:
> <!--#include virtual="foo.ssi"--> or
> <!--#include virtual="/foo.ssi"--> if it's at the
> root or
> <!--#include virtual="/dude/foo.ssi"--> if it's in
> the 'dude' directory.
> Does that help? If not... a sample URL for us to
> look at would probably be
> best.
> - amanda
> > I understand that with SSI using file="" you can't
> use
> > ../ or absolute paths. What is the way around
> this? I
> > even tried /path/include.file on the server, but
> it
> > doesn't work. Is the virtual attribute for the
> > absolute URL of the file? I tried that as well and
> it
> > doesn't work.
> >
> > The files in the root directory work fine, but the
> sub
> > directories don't because it requires using ../ to
> get
> > to the file. Anyone know what I can do to make the
> sub
> > directories work? I'm using Netscape Enterprise
> Server
> > 4 SP 2 running on Solaris.
> ---------------------------------------
> For unsubscribe and other options, including
> the Tip Harvester and archive of TheList go to:
> http://lists.evolt.org Workers of the Web, evolt ! 

Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

More information about the thelist mailing list