[thelist] ColdFusion MX, CFEXECUTE, and returning the output

Jay Dorsey evolt at jaydorsey.com
Sat Jan 25 17:15:06 CST 2003

I'm running the dev version of ColdFusion MX on Windows XP, and trying
to use the cfexecute tag to run a python script that I've written.
 According to the documentation, when no outputfile is specified on the
cfexecute, the output is sent right to the screen.  Running the
cfexecute WITH an outputfile specified I get the output of the python
script just fine; when I leave the outputfile OUT of the tag, I get
nothing.  I've tried wrapping a cfsavecontent around the cfexecute, I
still get nothing.  I've even tried running cfexecute with ipconfig,
with the same results.  I've included a sample page below, using
ipconfig (I'm fairly certain I don't have to specifiy the full path -
when I use an outputfile, I get the proper results; though when I call
my pyton script, I DO use the full path).  Any ideas?





<cfif request_method eq "post">
submitted! content below:<br />
<cfexecute name='ipconfig'></cfexecute>
<br />
content above
<form action="python.cfm" method="post">
<!--- this form is used for my python script, disregard --->
<textarea name="text"></textarea>
<input type="submit" />

More information about the thelist mailing list