[thelist] CVS Desperation

Peter Smulders schmolle at pobox.com
Sun Oct 12 16:37:59 CDT 2003

Hi Burhan,

Burhan Khalid wrote:
> ... headache trying to setup CVS for remote logins on a linux system.
> CVS works fine locally, I can checkout and commit changes, but
> whenever I try to login remotely, the server responds with "directory
> not found" or "client closed connection".  I can checkout files fine
> with cvs (from a SSH), but when I try to logon to the server itself
> (from the same machine, using the IP), it doesn't work.

> Checked permissions (cvs user, cvs group) Edited the passwd file
> under CVSROOT Created a separate cvs-only user and added that to
> passwd file

> Read the manual at cvshome.org and the "The CVS Handbook" Tried
> logging in as my normal user (member of cvs group), cvs-only user,
> even root.

Shooting from the hip: have you pre-endcoded the password in the passwd
file? Entering the password in plaintext will not work.

Second shot: if you are using an empty password (as you may very well
have tried), you may need to enter th
at empty password at the connection prompt (if you get that far) by
entering a space (or any character, in fact), followed by CTRL+U (which
is the 'delete-to-beginning-of-line' terminal command). This makes the
client think you entered a password, with the password being the empty
one. I have seen cases where not entering a password was just not good
enough for the client, even though the server would happily accept it.

Other than that, I am more than happy to debug with you. Can you tell me:

- Server OS, cvs version?
- Client OS, cvs version and flavour? (graphical, command line, etc)
- Connection details? Something like:

'Server, Solaris, cvs accessed through inetd, user/passwd internal to
cvs setup (as opposed to hitchiking on system/host usernames, as in
/etc/passwd ), client on Linux, plain TCP/IP connection to server'

- Transcript (copy and paste, please, rather than paraphrasing) of a
sample session.

The first three items could make up a few dozen possible combinations
without even leaving command line tools, so please be specific.

If you can, please include a sample session of a (successful) local
connection, which you say works.

As an aside: given you ask detailed and polite questions (like the one
you asked here, enriched with answers to my questions above) you can get
very good results from the cvs-users mailing list. Dig around on the
cvshome.org site for details; I haven't been around that place for
almost a year. It is (or at least used to be) an open forum, so you can
ask questions without being a member.

Having said that: if you have a learning curve to go with CVS, enduring
the high list volume and (for some strange reason) high flamability of
some members for a while can be very instructive. Last time I checked,
the FAQ was of very little use, but the list archives are a real
treasure trove. (since there is some cross-fertilisation with a usenet
group, Google groups might also help)

Awaiting your detailed problems,


More information about the thelist mailing list