[thesite] Bug?

David McCreath mccreath at ak.net
Sun Dec 3 12:20:15 CST 2000

Hi, Jeff --

> : documents, I was trying to find the comment
> : search (which I still haven't found... is it an
> : admin function?).
> :~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> http://test.evolt.org/comment/index.cfm
> it's not really an admin function, but it's also not fully developed yet
> either.  i'm still having some issues with the search functionality.

Okey doke. I'll go ahead and fix the HTML.

> : So I tried "delete" and I got a 404 message, but when
> : I went back to the article that the comment was attached
> : to, I realized that I had deleted it! It was one of Elfur's
> i'm curious what the url looked like.  could you reconstruct what you did
> and post it?

Well, I just tried and I can't. I'll play some more with it later. I know
that I started by clicking on the grrr! link, then I started taking stuff in
and out of the query string. At some point I put "delete" in as the action,
but I can't remember specifically what I had done up to that point. I'll see
if I can reconstruct it.

> well, since only the author of a comment or an admin should be able to
> delete a comment, i just went ahead and put in that exact logic.

You mean you added more logic between the time that I deleted the comment
and now? Because that's exactly what I was able to do; I deleted somebody
else's comment. What I did just now was go to one of your comments:


and type in "delete" instead of "grrr", and I got a CF processing error.
Then I took out the /grrr/ directory and replaced the action with "delete"
again, and got another CF error. If you've changed the code, then I think
you fixed it. I'll play with it more later.


More information about the thesite mailing list